Placeholder

ΠΑΝΕΛΛΑΔΙΚΕΣ

Ενδεικτικές απαντήσεις στο μάθημα Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον που διαγωνίστηκαν σήμερα οι υποψήφιοι

Δημοσίευση: 13/06/2018
Alt Text: 
Εξετάσεις
Εξετάσεις
Title Text: 
Εξετάσεις
ΡΕΠΟΡΤΑΖ ESOS

Ο εκπαιδευτικός των εκπαιδευτηρίων “Πολύτροπη Αρμονία” Θανάσης Δρίβας, δίνει τις ακόλουθες ενδεικτικές απαντήσεις  στα θέματα του μαθήματος   Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον, που διαγωνίστηκαν σήμερα οι υποψήφιοι:

ΘΕΜΑ Α
Α1.
1.    Σωστό
2.    Σωστό
3.    Λάθος
4.    Λάθος
5.    Σωστό

Α2.
α. Σχολικό βιβλίο, σελίδα 58
Με τον όρο στατική δομή δεδομένων εννοείται ότι το ακριβές μέγεθος της απαιτούμενης κύριας μνήμης καθορίζεται κατά τη στιγμή του προγραμματισμού τους, και κατά συνέπεια κατά τη στιγμή της μετάφρασής τους και όχι κατά τη στιγμή της εκτέλεσης τους προγράμματος. οι στατικές δομές υλοποιούνται με πίνακες που μας είναι γνωστοί από άλλα μαθήματα και υποστηρίζονται από κάθε γλώσσα προγραμματισμού.
β.  Σχολικό βιβλίο, σελίδα 115
Τυπικό είναι το σύνολο των κανόνων που ορίζει τις μορφές με τις οποίες
μία λέξη είναι αποδεκτή. Για παράδειγμα, στην ελληνική γλώσσα οι λέξεις
γλώσσα, γλώσσας, γλώσσες είναι δεκτές, ενώ η λέξη γλώσσατ δεν είναι
αποδεκτή.
Συντακτικό είναι το σύνολο των κανόνων που καθορίζει τη νομιμότητα
της διάταξης και της σύνδεσης των λέξεων της γλώσσας για τη δημιουργία προτάσεων.

Α3.
(1)    ηλικία >= 18 ΚΑΙ ηλικία <=21
(2)    φύλο=Ά’ Ή φύλο=’Θ’
(3)    (ύψος>1.70 και φύλο=’Α’) Ή (ύψος>1.60 και φύλο=’Θ’)

Α4.
(α) i+3
(β) i^2
(γ) 2^i
(δ) 2*i+1
(ε) 1/(i+1)

ΘΕΜΑ Β
Β1.
(1) 2
(2) ΨΕΥΔΗΣ
(3) i←i+1
(4) >
(5) ΑΛΗΘΗΣ

Β2
1Η λύση
Διάβασε Σ
Διάβασε Α
Όσο Α<>0 επανάλαβε
    Σ←Σ+Α
    Διάβασε Α
Τέλος_επανάληψης
Εμφάνισε Σ

2Η λύση
Διάβασε Σ
Αρχή_επανάληψης
    Διάβασε Α
    Αν Α<>0 τότε
        Σ ← Σ + Α
    Τέλος_αν
Μέχρις_οτου Α=0
Εμφάνισε Σ

ΘΕΜΑ Γ

Πρόγραμμα ΘΕΜΑΓ
Μεταβλητές
    Ακέραιες: AΠΟΘ, ΠΛ, ΗΜΕΡ, ΑΘΡ, ΜΕΓ, ΕΙΣ, ΕΞ, ΑΘΡΑΠ
    Χαρακτήρες: ΑΠΑΝΤ
    Πραγματικές: MO,M
Αρχή
    ΑΠΟΘ←0
    ΑΘΡΑΠ←0
    ΠΛ←0
    ΗΜΕΡ ← 0
    ΑΘΡ ← 0
    ΜΕΓ ← -1
    Αρχή_επανάληψης
        Αρχή_επανάληψης    
            Διάβασε ΕΙΣ, ΕΞ
        Μέχρις_ότου ΑΠΟΘ+ΕΙΣ-ΕΞ>=0 και ΑΠΟΘ+ΕΙΣ-ΕΞ <= 170
        ΑΠΟΘ ← ΑΠΟΘ + ΕΙΣ-ΕΞ
        Αν ΕΙΣ > ΜΕΓ τότε
            ΜΕΓ ← ΕΙΣ
        Τέλος_αν
        ΑΘΡ ← ΑΘΡ + ΕΙΣ + ΕΞ
        ΗΜΕΡ ← ΗΜΕΡ + 1
        Αν ΑΠΟΘ > = 10 τότε
            ΠΛ ← ΠΛ +1
        Τέλος_αν
ΑΘΡΑΠ ← ΑΘΡΑΠ + ΑΠΟΘ
        Γράψε ‘Τέλος εισαγωγής στοιχείων ; ΝΑΙ / ΟΧΙ ‘
        Διάβασε ΑΠΑΝΤ
Μέχρις_ότου ΑΠΑΝΤ=’ΝΑΙ’
Γράψε ΜΕΓ
ΜΟ ← ΑΘΡ / ΗΜΕΡ
Γράψε ΜΟ, ΠΛ
Μ ← ΑΘΡΑΠ / ΗΜΕΡ
Γράψε Μ
Τέλος_προγράμματος

ΘΕΜΑ Δ

Πρόγραμμα ΘΕΜΑΔ
Μεταβλητές
    Ακέραιες: N, κ, λ, ΕΠ[20,12],Σ, ΠΛ, max
    Χαρακτήρες: Π[20], β1,
    Πραγματικές: MO[20], β2
Αρχή
    ! Δ2
    Αρχή_επανάληψης
        Διάβασε Ν
    Μέχρις_ότου Ν <= 20
    Για κ από 1 μέχρι Ν
        Διάβασε Π[κ]
    Τέλος_επανάληψης
    ! Δ3
    Για λ από 1 μέχρι 12
        Για κ από 1 μέχρι Ν
            Γράψε Π[κ]
            Κάλεσε Υ_Ε(max)
            ΕΠ[κ,λ]←max
        Τέλος_επανάληψης
    Τέλος_επανάληψης
    ! Δ4
    Για κ από 1 μέχρι Ν
        Σ←0
        Για λ από 1 μέχρι 12
            Σ←Σ+ΕΠ[κ,λ]
        Τέλος_επανάληψης
        ΜΟ[κ]←Σ/12
    Τέλος_επανάληψης
    Για κ από 2 μέχρι Ν
        Για λ από Ν μέχρι κ με_βήμα -1
            Αν Π[λ-1]>Π[λ] τότε
                β1←Π[λ-1]
                Π[λ-1]←Π[λ]
                Π[λ]←β1
β2←ΜΟ[λ-1]
                ΜΟ[λ-1]←ΜΟ[λ]
                ΜΟ[λ]←β2
            Τέλος_αν
        Τέλος_επανάληψης
    Τέλος_επανάληψης
    ΠΛ←0
    Για κ από 1 μέχρι Ν
        Αν ΜΟ[κ]>7 τότε        
            Γράψε ΟΝ[κ]
            ΠΛ←ΠΛ+1
        Τέλος_αν
    Τέλος_επανάληψης
    Αν ΠΛ=0 τότε
        Γράψε ‘Κανένας ποταμός με μέσο όρο πάνω από 7’
    Τέλος_αν
Τέλος_προγράμματος

! Δ5
Διαδικασία Υ_Ε(μεγ)
Μεταβλητές
    Ακέραιες: μεγ, τιμή
Αρχή
    μεγ←-1
    Διάβασε τιμή
    Όσο τιμή<>0 επανάλαβε
        Αν τιμη>μεγ τότε
            μεγ←τιμή
        τέλος_αν
Διάβασε τιμή
    Τέλος_επανάληψης
Τέλος_διαδικασίας
        

 

Σχολιάστε το άρθρο

Συκοφαντικά και υβριστικά σχόλια δεν δημοσιεύονται και διαγράφονται. Επίσης δεν επιτρέπεται στα σχόλια να αναγράφονται links τα οποία διαγράφονται. Το esos δεν φέρει ευθύνη για τα επώνυμα ή ανώνυμα σχόλια που φιλοξενεί. Σε περίπτωση που θεωρείτε πως θίγεστε από κάποιο εξ αυτών, επικοινωνήστε μέσω της φόρμας επικοινωνίας έτσι ώστε να αφαιρεθεί.

e-epimorfosi.aegean

ΠΕΡΙΣΣΟΤΕΡΑ ΑΡΘΡΑ