Τα σχόλια και οι απαντήσεις στα θέματα «Ανάπτυξης Εφαρμογών σε Προγραμματιστικό Περιβάλλον» από τους καθηγητές Πληροφορικής

07/06/2014

Άκουσε το άρθρο

Τα θέματα στο σύνολό τους ήταν κλιμακούμενου βαθμού δυσκολίας με αρκετά ερωτήματα να απαιτούν ιδιαίτερη συγκέντρωση και μεγάλη προσοχή στις λεπτομέρειες, προκειμένου να μην χάσουν μονάδες. Η κάλυψη της διδαχθείσας ύλης για μια ακόμη χρονιά δεν ήταν πλήρης αφού απουσίαζε σχεδόν τελείως το κεφάλαιο 10, ένα πολύ σημαντικό κεφάλαιο για τους στόχους του μαθήματος του Προγραμματισμού, που πολλές φορές δεν καλύπτεται επαρκώς στα σχολεία λόγω του περιορισμένου χρόνου του μαθήματος στο ωρολόγιο πρόγραμμα.
Τα παραπάνω τονίζει η Πανελλήνια Ενωση Καθηγητών Πληροφορικής , στο γενικό σχόλιο για τα θέματα του μαθήματος Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον,που διαγωνίστηκαν σήμερα οι υποψήφιοι για τα ΑΕΙ, Τεχνολογικής κατεύθυνσης και υπογραμμίζει τα εξής: «Ενώ η πρώτη εικόνα από τα θέματα ήταν πως είναι ευκολότερα από τα προηγούμενα των τελευταίων ετών, αυτή η εικόνα ανατρέπεται από διεξοδικότερη ματιά και από τα σχόλια των μαθητών, καθώς τα θέματα κρίνονται σε λεπτομέρειες τους  απαιτητικά.
Μια πρώτη εκτίμηση είναι ότι οι βαθμολογίες θα συγκεντρωθούν στα δύο άκρα (κάτω από 30 και πάνω από 70) δηλαδή μια αντιστροφή της καμπύλης Gauss».

ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ΄ ΤΑΞΗΣ
ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 6 ΙΟΥΝΙΟΥ 2014
ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ
ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ)           
Θέμα Α.
Α1.    
1. Σ    2. Σ    3. Σ    4. Λ    5. Σ
Α2.
α. ένας εκ των τελεστών:   >, <, =, <>, >=, <=
β. ένας εκ των τελεστών:  ΟΧΙ, Ή, ΚΑΙ
γ. μια εκ των τιμών: ΑΛΗΘΗΣ, ΨΕΥΔΗΣ
δ. μια μονή συνθήκη όπως η: α > 0
ε. μια σύνθετη (διπλή) συνθήκη όπως η: α > 0 και β < 5
Α3.
α. (ΟΧΙ (9 mod 5 = 20 – 4 * 2 ^ 2)) Ή (8 > 4 ΚΑΙ "X" > "ψ")
β. (ΟΧΙ (4 = 4)) Ή (8 > 4 ΚΑΙ "X" > "Ψ”)
γ. (ΟΧΙ ΑΛΗΘΗΣ) Ή (ΑΛΗΘΗΣ ΚΑΙ ΨΕΥΔΗΣ)
δ. ΨΕΥΔΗΣ
Α4. α. Σελίδα 180 σχολικού Βιβλίου Μαθητή
β, γ, δ. Σελίδα 138 Σχολικού Βιβλίου Μαθητή
Α5.
Α←101
Β ←0
Αρχή_επανάληψης
    Β ← Β + Α
    Α ← Α + 2
Μέχρις_ότου Α > 200
Εμφάνισε Β
ΘΕΜΑ Β
Β1.
(1) Μια εκ των τιμών: κ, 30, κ+1, οποιαδήποτε τιμή στο διάστημα [κ, 30]
(2) >
(3) i
(4), (5) Π[θ], Π[κ] ή ανάποδα
Β2.
Αλγόριθμος Β2
i ←1
s ←0
Όσο i <= 200 επανάλαβε
    Διάβασε m
    Αν m > 10 τότε s ←m + s
    i ←i + 1
Τέλος_επανάληψης
Εκτύπωσε S
Τέλος Β2
Θέμα Γ
Αλγόριθμος ΘέμαΓ
max← -1
Σmax←0
Σ10 ←0
Σκόστος ←0
Διάβασε κωδικός
Όσο κωδικός <> 0 επανάλαβε  ! Γ1
    Διάβασε τιμή, τεμάχια
Σκόστος ←Σκόστος + τιμή * τεμάχια
Αν τιμή > 10 τότε
 Σ10←Σ10 + τεμάχια
Τέλος_αν
Αν τιμή > max τότε
        max← τιμή
        ΣΜax←τεμάχια
Αλλιώς_αν τιμή = max τότε
        Σmax← Σmax + τεμάχια
Τέλος_αν
Διάβασε κωδικός
Τέλος_επανάληψης
Εμφάνισε Σ10, Σmax  ! Γ3, Γ4
Αν Σκόστος <= 500 τότε
    Εμφάνισε "ΠΛΗΡΩΜΗ ΜΕΤΡΗΤΟΙΣ"
Αλλιώς
    πλδ ←0
δόση←20
ποσό ←0
Όσο ποσό < Σκόστος επανάλαβε
        ποσό←ποσό + δόση
        δόση←δόση + 5
        πλδ ←πλδ + 1
Τέλος_επανάληψης
Εμφάνισε πλδ
Τέλος_αν
Τέλος ΘέμαΓ
Θέμα Δ
Αλγόριθμος ΘέμαΔ
Για i από 1 μέχρι 10
    Διάβασε ΟΝ[i]
    Για j από 1 μέχρι 28
        Διάβασε ΕΠ[i, j]
    Τέλος_επανάληψης
Τέλος_επανάληψης
Για i από 1 μέχρι 10
    Σ ←0
    Για j από 1 μέχρι 28
        Σ ←Σ + ΕΠ[i, j]
    Τέλος_επανάληψης
    Εμφάνισε ΟΝ[i], Σ
Τέλος_επανάληψης
υπάρχει ←αληθής
Για i από 1 μέχρι 10
    κ ←0
    Για j από 1 μέχρι 28
        Αν ΕΠ[i, j] <= 500 τότε
κ ←κ + 1
Τέλος_αν
    Τέλος_επανάληψης
    Αν κ = 0 τότε
        Εμφάνισε ΟΝ[i]
        υπάρχει ←ψευδής
    Τέλος_αν
Τέλος_επανάληψης
Αν υπάρχει = ψευδής τότε
 Εμφάνισε "δεν υπάρχει"
Τέλος_αν

Αρχή_επανάληψης
    Διάβασε ονζ
    done ← ψευδής
    pos ←0
    i ←1
    Όσο done = ψευδής και i <= 10 επανάλαβε
        Αν ονζ = ΟΝ[i] τότε
            done ←αληθής
            pos ←i
        αλλιώς
            i ←i + 1
        Τέλος_αν
    Τέλος_επανάληψης
Μέχρις_ότου done = αληθής

Για β από 1 μέχρι 4
    Σ← 0
    Για κ από 1 μέχρι 7
        Σ ←Σ + ΕΠ[pos, (β-1)*7+κ]
    Τέλος_επανάληψης
    ΣΥΝ[β]← Σ
Τέλος_επανάληψης
max ←ΣΥΝ[1]
Για i από 2 μέχρι 4
    Αν ΣYN[i] > max τότε
max ←ΣYN[i]
Τέλος_αν
Τέλος_επανάληψης
Για i από 1 μέχρι 4
    Αν ΣYN[i] = max τότε
 Εμφάνισε i
Τέλος_αν
Τέλος_επανάληψης
Τέλος ΘέμαΔ
Μέρος 1ο. Σχολιασμός ανά θέμα
Θέμα Α
Α1.  Το καθιερωμένα θέμα με απαντήσεις τύπου Σωστού Λάθους.  Το βασικό πρόβλημα αυτού του τύπου θέματος είναι ότι οι απαντήσεις αντιγράφονται εύκολα.
Α2.  Εύκολο θέμα με αναφορά σε βασικές γνώσεις που πρέπει να έχει κάθε μαθητής
Α3.  Θέμα με λογική αποτίμηση εκφράσεων.  Αρκετά έξυπνο με μεταβλητές Χ, Υ και “Χ”, “Υ”
Θετική κρίνεται η αποτίμηση  της βαθμολογίας του σε βήματα.
Α4.  Θέμα θεωρίας.  
Α5.  Τυπικό θέμα συμπλήρωσης κενών σε ένα αλγόριθμο χωρίς κάποια ιδιαίτερη δυσκολία.
Θέμα Β
Το θέμα Β δεν κρίνεται συνολικά  ιδιαίτερα απαιτητικό και δύσκολο. Για άλλη μια χρονιά η ΚΕΕ επέλεξε να μην εξετάσει πίνακα τιμών.
Β1.  Πολύ καλή η επιλογή ενός ακόμα αλγορίθμου ταξινόμησης με εύκολη υλοποίηση κωδικοποίησης. Το θέμα θα μπορούσε να ζητά ολόκληρο τον αλγόριθμο, χωρίς συμπλήρωση κενού (κάτι που θα το καθιστούσε αρκετά πιο δύσκολο).  Η  παρουσίαση τμήματος του αλγορίθμου διευκολύνει την απάντησή του.
Β2. Θέμα μετατροπής ενός  διαγράμματος σε ψευδογλώσσα με παγίδα.  Η παγίδα  βρίσκεται στην αρχική  συνθήκη του διαγράμματος από την οποία η αληθής τιμή οδηγεί στην έξοδο του βρόχου.  Η ακριβής υλοποίηση αυτής της δομής οδηγεί στην έκφραση της συνθήκης  με χρήση λογικού τελεστή ΟΧΙ.
Θέμα Γ
Η διατύπωση του θέματος αυτού παρουσιάζει ορισμένες ατέλειες. Το ερώτημα Γ1 αναφέρεται σε κάθε προϊόν ενώ το ερώτημα Γ2 σε λογαριασμό χωρίς  να είναι σαφές αν ο λογαριασμός  αφορά ένα προϊόν ή το σύνολο των προϊόντων.  Η  απουσία σε αυτό κάποιας λέξης που να παραπέμπει σε σύνολο λογαριασμού,  μπέρδεψε κάποιους μαθητές που τοποθέτησαν το σχετικό τμήμα εντολών στο εσωτερικό της επανάληψης του ερωτήματος Γ1..
Επίσης, η ανάγκη επεξεργασίας όλων των μεγίστων τιμών χωρίς τη χρήση πίνακα, καθιστά το ερώτημα Γ4 (Μονάδες 6),  αυξημένου βαθμού δυσκολίας για την πλειονότητα των μαθητών. Το Γ3 δεν έχει κάποια ιδιαίτερη δυσκολία ή παγίδα. Να παρατηρήσουμε τέλος ότι η λογική που χρησιμοποιεί το  ερώτημα Γ2, έχει εξεταστεί και   παλιότερα.
Θέμα Δ
Απαιτητικό θέμα που περιείχε πολλές επεξεργασίες σε πίνακες, ειδικά στα τελευταίο ερώτημα, χωρίς αντίκρυσμα στη βαθμονόμηση. Απαιτεί προσοχή στην βαθμολόγηση με προσεκτική κατανομή των μονάδων σε κάθε επεξεργασία αντίστοιχα. Την δυσκολία βαθμολόγησης επιτείνει η χρήση εναλλακτικών λύσεων (π.χ τρισδιάστατοι πίνακες) από σημαντικό αριθμό μαθητών.
Μέρος 2ο. ΓΕΝΙΚΟΣ ΣΧΟΛΙΑΣΜΟΣ
Τα θέματα στο σύνολό τους ήταν κλιμακούμενου βαθμού δυσκολίας με αρκετά ερωτήματα να απαιτούν ιδιαίτερη συγκέντρωση και μεγάλη προσοχή στις λεπτομέρειες, προκειμένου να μην χάσουν μονάδες. Η κάλυψη της διδαχθείσας ύλης για μια ακόμη χρονιά δεν ήταν πλήρης αφού απουσίαζε σχεδόν τελείως το κεφάλαιο 10, ένα πολύ σημαντικό κεφάλαιο για τους στόχους του μαθήματος του Προγραμματισμού, που πολλές φορές δεν καλύπτεται επαρκώς στα σχολεία λόγω του περιορισμένου χρόνου του μαθήματος στο ωρολόγιο πρόγραμμα.
Ενώ η πρώτη εικόνα από τα θέματα ήταν πως είναι ευκολότερα από τα προηγούμενα των τελευταίων ετών, αυτή η εικόνα ανατρέπεται από διεξοδικότερη ματιά και από τα σχόλια των μαθητών, καθώς τα θέματα κρίνονται σε λεπτομέρειες τους  απαιτητικά.
Μια πρώτη εκτίμηση είναι ότι οι βαθμολογίες θα συγκεντρωθούν στα δύο άκρα (κάτω από 30 και πάνω από 70) δηλαδή μια αντιστροφή της καμπύλης Gauss.
Τέλος, επειδή ένα τέτοιο μάθημα συμβάλλει  στην ανάπτυξη της αναλυτικής και συνθετικής ικανότητας στην επίλυση αυθεντικών προβλημάτων, θεμέλιο λίθο της σύγχρονης υπολογιστικής σκέψης, θεωρούμε αυτονόητη την ύπαρξη και εξέτασή του σε κάθε τύπου Λυκείου, για μαθητές που κατευθύνονται σε Τεχνολογικές ή Οικονομικές σχολές, σε ένα σύγχρονο εκπαιδευτικό περιβάλλον. Οι Σχολές αυτές αναδεικνύονται ως δημοφιλέστερες σε όλες τις σχετικές έρευνες και επιθυμούν την ύπαρξη ενός τέτοιου μαθήματος. Επίσης να υπενθυμίσουμε ότι και οι μαθητές, σύμφωνα με σχετική έρευνα του ίδιου του Υπουργείου Παιδείας, επιθυμούν τη διδασκαλία της Πληροφορικής.
Ευχόμαστε καλά αποτελέσματα σε όλους τους μαθητές και υλοποίηση των στόχων τους.
Για την ΠΕΚΑΠ
Σταύρος Κωτσάκης
Βαγγέλης Κανίδης
Παναγιώτης Τσιωτάκης
Δημήτρης Γιάτας

ΠΡΟΣΘΗΚΗ ΣΧΟΛΙΟΥ

Συκοφαντικά και υβριστικά σχόλια δεν δημοσιεύονται και διαγράφονται. Επίσης δεν επιτρέπεται στα σχόλια να αναγράφονται links τα οποία διαγράφονται. Το esos δεν φέρει ευθύνη για τα επώνυμα ή ανώνυμα σχόλια που φιλοξενεί. Σε περίπτωση που θεωρείτε πως θίγεστε από κάποιο εξ αυτών, επικοινωνήστε μέσω της φόρμας επικοινωνίας έτσι ώστε να αφαιρεθεί.

ΠΡΟΣΦΑΤΑ ΑΡΘΡΑ